Website down
Incident Report for Connecticut College
Resolved
The website is operational again
Posted Dec 20, 2023 - 10:10 EST
Identified
The website was down this morning due to a server issue with the Content Management system.
Posted Dec 20, 2023 - 09:00 EST
This incident affected: www.