Google Resources Unavailable

Incident Report for Connecticut College

Resolved

This incident has been resolved
Posted Oct 16, 2025 - 13:55 EDT

Investigating

We are currently investigating the issue.
Posted Oct 16, 2025 - 13:35 EDT
This incident affected: Google Workspace.