Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 01, 2025 - 22:00 EST
Scheduled
Enterprise Systems team in coordination with Ellucian will perform quarterly upgrades to our Ellucian Banner and Self-Service systems. These upgrades will keep the software current with security patches, regulatory updates, defect resolutions, as well as lighten the load on future upgrades over the next couple months.
What to Expect:
The following systems will be unavailable starting at 10pm.
Banner Administrative Pages Banner Self-Service Banner WorkFlow Student Transcripts CCPay payments via Self-Service Application Manager/UC4 processing IDM Auto-provisioning Overnight/daily data refreshes from Banner delayed
Posted Feb 28, 2025 - 15:23 EST
This scheduled maintenance affected: Banner Admin and Banner Self Service.