Intermittent issues with DUO Authentication

Incident Report for Connecticut College

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 09:55 EST

Update

The issue causing the Duo error messages has been identified and resolved. Thank you for your patience.
Posted Feb 26, 2026 - 09:54 EST

Investigating

Some users are getting "MFA Provider Unavailable" when trying to access College resources. Our technical team is investigating.
Posted Feb 26, 2026 - 09:16 EST
This incident affected: Duo.