Web HelpDesk Email Issues

Incident Report for Connecticut College

Update

Access to the IT Service Desk ticketing system has been restored, however, email updates are still being addressed. Thank you for your patience.
Posted May 13, 2025 - 13:09 EDT

Update

The IT Service Ticketing system is unavailable. The team is working to correct the problems that were reported earlier this morning.
Posted May 13, 2025 - 10:32 EDT

Identified

The team has identified an issue with emails updates to IT Service Desk tickets and emails from the IT Service Desk ticketing system. You can call the IT Service Desk at 860-439-4357(HELP) to report an issue or check the status of your open ticket. You can also login to the ticketing system directly at webhelpdesk.conncoll.edu to update your existing ticket or create a new one.
Posted May 13, 2025 - 09:54 EDT
This incident affects: Web Help Desk(WHD).