Banner Self Service access has been resolved. Thank you for your patience.
Posted Mar 06, 2026 - 14:06 EST
Update
We are continuing to work on a fix for this issue.
Posted Mar 06, 2026 - 14:03 EST
Update
Banner Self-Service remains unavailable.
We have escalated this issue to the highest levels at Ellucian, and their technical team is actively working to restore service. We understand the impact this has on your work and are pushing for resolution as quickly as possible.
We will provide another update at 2PM or sooner if service is restored. Thank you for your patience.
Posted Mar 06, 2026 - 13:01 EST
Identified
You may be receiving a message "Application Not Authorized to use CAS" The technical team is working with a third-party vendor to resolve the issue.
Posted Mar 06, 2026 - 09:28 EST
This incident affected: Banner Admin, Banner Self Service, and DegreeWorks.