Moodle Unavailable
Incident Report for Connecticut College
Resolved
Service has been restored.
Posted Jan 29, 2024 - 14:25 EST
Investigating
The team is investigating. We appreciate your patience.
Posted Jan 29, 2024 - 13:26 EST
This incident affected: Moodle (LMS).