Moodle Unavailable

Incident Report for Connecticut College

Resolved

Moodle is available again
Posted Aug 26, 2025 - 10:17 EDT

Investigating

Moodle is currently unavailable, we are working with the Moodle support team to identify the issue.
Posted Aug 26, 2025 - 09:57 EDT
This incident affected: Moodle (LMS).