Papercut Printing Unavailable

Incident Report for Connecticut College

Resolved

The issue has been identified and resolved. Thank you for your patience.
Posted Sep 10, 2026 - 08:59 EDT

Investigating

The technicians are investigating the issue at this time.
Posted Sep 10, 2026 - 08:40 EDT
This incident affected: Papercut printing.