Moodle Access
Incident Report for Connecticut College
Resolved
Connectivity to Moodle has been restored.
Posted Jan 29, 2024 - 16:36 EST
Investigating
Users are reporting slowness and intermittent connectivity issues. The vendor is investigating the issue.
Posted Jan 29, 2024 - 15:08 EST
This incident affected: Moodle (LMS).