Moodle Campus Unavailable

Incident Report for Connecticut College

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 14:53 EDT

Update

This was resolved. There were issues with the server nodes, but the system was brought back up rather quickly
Posted Oct 27, 2025 - 12:47 EDT

Investigating

We are currently investigating the issue
Posted Oct 27, 2025 - 08:43 EDT
This incident affected: Moodle Campus.