Login Issues

Incident Report for Connecticut College

Resolved

The issue has been resolved
Posted Feb 16, 2026 - 09:18 EST

Investigating

There are some issues with authentication, you may receive an "Upstream connect error". While the tech team continues to investigate, you may be able to login after multiple attempts. We apologize for this inconvenience and appreciate your patience.
Posted Feb 16, 2026 - 08:00 EST
This incident affected: SSO - CAS.