Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 05, 2025 - 22:00 EDT
Scheduled
The Enterprise Systems team in coordination with Ellucian will perform monthly operating system server patching to all Ellucian application and database servers. These patches will keep the server and database software current with security patches, regulatory updates, defect resolutions.
What to Expect: The following systems will be unavailable starting at 10pm.
Banner Administrative Pages Banner Self-Service Banner WorkFlow Student Transcripts DegreeWorks Banner WorkFlow CCPay payments via Self-Service Application Manager/UC4 processing IDM Auto-provisioning Overnight/daily data refreshes from Banner delayed
Posted Apr 04, 2025 - 10:40 EDT
This scheduled maintenance affected: Banner Admin, Banner Self Service, and DegreeWorks.