Banner Admin
Incident Report for Connecticut College
Resolved
The issue has been identified and resolved.
Posted Oct 24, 2024 - 11:55 EDT
Update
We are continuing to work with third-party vendors to resolve the issue.
Posted Oct 24, 2024 - 10:00 EDT
Investigating
Banner Admin Pages are down in Production and Test Environment. Banner Self-Service is not impacted.
Posted Oct 23, 2024 - 09:19 EDT
This incident affected: Banner Admin.